Commit 9dc73162 authored by Drew's avatar Drew

Add platform to tarball name

Bump version to 1.0.1

link-product => link-with-product
parent a43151c2
......@@ -14,7 +14,7 @@
(package
:name "PackageFramework"
:version "1.0"
:version "1.0.1"
:external-packages [
{
:url "https://github.com/AnarchyTools/atfoundation.git"
......@@ -28,7 +28,7 @@
:output-type "executable"
:name "package_framework"
:dependencies ["atfoundation.atfoundation"]
:link-with ["atfoundation.a"]
:link-with-product ["atfoundation.a"]
:compile-options ["-g"]
:executable-name "package-framework"
}
......
......@@ -163,7 +163,7 @@ class PackageFramework {
guard let packageVersion = env("ATBUILD_PACKAGE_VERSION") else {
fatalError("No package version / ATBUILD_PACKAGE_VERSION")
}
let tarxz = "bin/\(name)-\(packageVersion).tar.xz"
let tarxz = "bin/\(name)-\(packageVersion)-\(atbuildPlatform).tar.xz"
//detect compression level
let fc: Bool
if env("ATBUILD_CONFIGURATION_FAST_COMPILE")=="1" {
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment