Commit f26d2ada authored by Drew's avatar Drew

Depend on build-essential

parent bcaa89b8
Pipeline #1857 passed with stage
...@@ -2,7 +2,7 @@ linux: ...@@ -2,7 +2,7 @@ linux:
stage: build stage: build
script: script:
- apt-get update - apt-get update
- apt-get install --no-install-recommends -y dh-make devscripts fakeroot - apt-get install --no-install-recommends -y dh-make devscripts fakeroot build-essential
# use package-deb to package itself! # use package-deb to package itself!
# yo dawg # yo dawg
- ./bin/package-deb.atbin/package-deb --name package-deb --version 0.1 --depends "devscripts, dh-make" - ./bin/package-deb.atbin/package-deb --name package-deb --version 0.1 --depends "devscripts, dh-make"
......
...@@ -30,6 +30,11 @@ if [ $(dpkg-query -W -f='${Status}' fakeroot 2>/dev/null | grep -c "ok installed ...@@ -30,6 +30,11 @@ if [ $(dpkg-query -W -f='${Status}' fakeroot 2>/dev/null | grep -c "ok installed
exit 1 exit 1
fi fi
if [ $(dpkg-query -W -f='${Status}' build-essential 2>/dev/null | grep -c "ok installed") -eq 0 ]; then
echo "build-essential not installed; apt-get install build-essential"
exit 1
fi
# parse arguments # parse arguments
while :; do while :; do
case $1 in case $1 in
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment